Multi-D Acquisition saved image stacks are fault and refuse to open in Icy

Home Forums Bug Reports Multi-D Acquisition saved image stacks are fault and refuse to open in Icy

Tagged: ,

  • MasoudR

    Hey Icy crew,

    my post was automatically marked as spam so I’m trying again without the embedded images…

    I’m having some trouble with my Icy-MicroManager saved Image stacks of multiple positions. I’m having several issues so I’ll cut this post into parts:

    1. Opening a file through drag and drop or the Recent Files menu gives an error:

    This is making the only way for me to open image stacks through the ‘Open…’ file browser.

    [/crayon]

           2. Saved image stack from multiple-positions acquisition is a mess of what seems to be a mapping of the other positions.

    I’m using multiple positions, using default position names (Pos0, Pos1, etc.). When I open the first file (Pos0) I get this odd mess of miniature versions of what seems to be the first image of all the other image stack files jumbled into small squares.

    I remember that in an older version of Icy, when I dragged and dropped such a file into icy it would open a window where I could select which files from that acquisition I wanted to open (e.g. just Pos 0, Pos3 and Pos4 if I wanted). Perhaps this is an error caused by something going wrong with that function?

    These files open properly in ImageJ, so there doesn’t seem to be anything wrong with the image stack itself. I’m not sure if this only happens with the first file (Pos0) or if the others are a similar mess, the reason I can’t determine this is my final point.

           3. Opening a file from such an acquisition (lets say Pos2), will automatically open Pos0 instead.

    No matter which one you select you will automatically get Pos0. Again, this does not happen in ImageJ so the files can still be accessed there.

    Looking at the sequence properties we find that the path points to the correct file, Pos2, yet the name and the contents of the file are Pos0:

     

    Any idea if this could be my mistake somehow, or if it is something that has been wrong with the Icy program or MM plugin?

    Let me know if you need my files. I’ll provide a MEGA link since the smallest acquisition data set is 200MB.

     

    Stephane Dallongeville

    Hi Masoud,

    We will try to replicate your different problems using Micro-Manager with Multi-D acquisition and multi position and get back to you after our discovers. About the automatic stitching problem : you can disable it, just select “separate files” for grouping mode :

    So it will allow you to open independent image, otherwise grouping will automatically try to stitch all the position acquired to build a big image out of it.

    Best,

    – Stephane

    MasoudR

    Hello Stephane,

    Did you have any luck replicating the problems?

    I’ve tried opening my tif files with the “Seperate files” option now and it gives me another error:

    [/crayon]

    They do open without error in imageJ

    MasoudR

    I just tried it with an older version of Icy: Icy 1.9.7.0

    With this, I can open my files. Using Seperate Files it gives me the series selection window, allowing me to open all files in a group.
    When using Group Files it gives me the tiled image again.

    With this, I can atleast analyse my data now using an older version. But it would be nice if this was fixed soon.

    Stephane Dallongeville

    Hi Masoud,

    After having investigating several hours about this problem, i can confirm you this is definitely a bug with Bio-Formats :-/ Icy is using version 5.9.2 of Bio-Formats but it looks like the bug is also present on the last version anyway.

    The problem comes from when we force un-grouping files (which Icy does when you select Separate files and when using drag & drop operation for a single file, ImageJ is always using grouping), in this case Bio-Formats has a bug parsing metadata of this multi series OME TIFF files.

    The bug happen at line 688 from loci.formats.in.OMETiffReader class in initFile(..) function :

    [/crayon]

    I guess they should used pix.getSizeZ() instead of core.get(i).sizeZ as at this point as core isn’t yet fully filled.

    Still hopefully there a way to display a single dataset, just try to open the associated metadata.txt file instead of the .tif file, in my case that is enough to get the proper dataset to open (unfortunately we cannot just disable un-grouping as other things would break).

    Hope that helps.

    – Stephane

    Stephane Dallongeville

    I realized you can exhibit the same bug in ImageJ by forcing un-grouping :

    MasoudR

    Dear Stephane,

    Thank you for all the support.

    Sadly some of the people in my lab have not turned on the option to create the metadata files, is there any other way to open them?

    Does OME know about the issue with bio-formats? Could Icy use a previous version where the bug is not present until they fix it?

     

    Cheers,

    Masoud

    Stephane Dallongeville

    Dear Masoud,

    I tried to find a way so you can open them in Icy, but the fastest solution i found is to drag the image on ImageJ app (into Icy) so it will open the image through ImageJ then convert it back to Icy format.

    We cannot revert on older version of Bio-Formats as there is others issues with them (it may fix this one, but bring others issues). What we can do is to patch the code ourself, that might be possible and probably the fastest way to go.

    Best,

    – Stephane

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.