ROI Statistics and running Icy from commandline on Linux

Home Forums Protocols ROI Statistics and running Icy from commandline on Linux

  • Ekkehard Görlach

    Hi,

    I am currently exploring how to run Icy from the command line as described in the Protocols documentation. For this I have a simple protocol: threshold the image and output some statistics into a text file. It runs fine in the Icy GUI on Windows and Linux (CentOS 7) and from the command line on windows. When I run it from the shell in Linux, however, the list of measures for the ROI statistics are always taken from the Icy settings file settings.xml and not from the protcol definition.

    From the output on the shell all looks fine:
    Initializing…

    Java(TM) SE Runtime Environment 1.8.0_162-b12 (64 bit)
    Running on Linux 3.10.0-862.2.3.el7.x86_64 (amd64)
    Number of processors : 40
    System total memory : 65.4 GB
    System available memory : 9.6 GB
    Max java memory : 14.5 GB
    Image cache initialized (reserved memory = 5681 MB, disk cache location = /tmp)
    Headless mode.

    VTK 6.3.0 library successfully loaded…

    Icy Version 2.0.3.0 started !

    Loading workflow…
    Sequence: /Data/Imaging/test@Day0_B03_G051_0001.oir – 800 x 800 x 37 x 1 – 1 ch (double)
    Exiting…
    EHCache disposed
    For now I am editing the settings file, but how could I find out why that is?

    Thanks a lot in advance,
    Ekkehard

    Stephane Dallongeville

    Hi Ekkehard,

    That is a weird issue to be honest !
    Can you post the command line and the protocol you are using so we can do some tests with it and try to sort it out ? If you can’t attach the protocol to the message you can even copy/paste its content here (it’s an XML file internally).

    Best,

    – Stephane

    Ekkehard Görlach

    Hi Stephane,
    thanks for looking into this !

    I have to correct myself: on both platforms the selection of variables are taken from the setting.xml file when running from the command line. That at least makes much more sense.

    The command line to start Icy is (all on one line):

    and the protocol is below. Thanks again for any advice – I am also happy to test things if that helps.

    Best,

    Ekkehard

     

     

    Stephane Dallongeville

    Hi Ekkehard,

    Thanks for providing the Protocol sample, it helped in reproducing the problem and indeed there was a regression here. We just updated ROI Statistics plugin so it should fix the issue.

    Thanks for reporting it !

    Best,

    – Stephane

    Ekkehard Görlach

    Hi Stephane,

    thank you so much ! All is fine now and my other protocols now run also nicely in parallel on our cluster environment without interfering with each other anymore. That really helps as I have a large number of data sets to analyze … 🙂

    Best,

    Ekkehard

     

    Stephane Dallongeville

    Hi Ekkehard,

    Glad to hear that 🙂 Thanks for confirming it’s now working as expected !

    Best,

    – Stephane

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.